>

Reply or forward via OWA gives “An unexpected error occurred and your request couldn’t be handled.”

When you try to reply or forward an e-mail via outlook web app (OWA) in exchange 2010 (in this case small business server 2011 exchange 2010 SP1) you get this error “An unexpected error occurred and your request couldn’t be handled.”

Request
Url: https://remote.domain.com:443/owa/?ae=PreFormAction&a=Reply&t=IPM.Note&id=RgAAAACGrFxHc9ijR44U4ykKtU4LBwAeKagN6lmQSpA1lJbfKp7EAAAALJcxAAAeKagN6lmQSpA1lJbfKp7EAAAcI3ykAAAJ&pspid=_1300011623710_69458484
User host address: ::1
User: User A
EX Address: /o=First Organization/ou=Exchange Administrative Group (FYDIBOHF23SPDLT)/cn=Recipients/cn=User A
SMTP Address: email@domain.com
OWA version: 14.1.218.13
Mailbox server: servername.domain.local

Exception
Exception type: System.ArgumentException
Exception message: imceaDomain must be a valid domain name.

Call stack

Microsoft.Exchange.Data.Storage.InboundConversionOptions.CheckImceaDomain(String imceaDomain)
Microsoft.Exchange.Data.Storage.InboundConversionOptions..ctor(String imceaDomain)
Microsoft.Exchange.Clients.Owa.Core.Utilities.CreateInboundConversionOptions(UserContext userContext)
Microsoft.Exchange.Clients.Owa.Core.ReplyForwardUtilities.CreateReplyOrReplyAllItem(BodyFormat bodyFormat, Item item, ReplyForwardFlags flags, Boolean replyAll, UserContext userContext, StoreObjectId parentFolderId)
Microsoft.Exchange.Clients.Owa.Core.ReplyForwardUtilities.CreateReplyItem(BodyFormat bodyFormat, Item item, ReplyForwardFlags flags, UserContext userContext, StoreObjectId parentFolderId)
Microsoft.Exchange.Clients.Owa.Premium.Controls.ItemReplyPreFormAction.Execute(OwaContext owaContext, ApplicationElement& applicationElement, String& type, String& state, String& action)
Microsoft.Exchange.Clients.Owa.Core.RequestDispatcher.DoFinalDispatch(OwaContext owaContext)
Microsoft.Exchange.Clients.Owa.Core.RequestDispatcher.InternalDispatchRequest(OwaContext owaContext)
Microsoft.Exchange.Clients.Owa.Core.RequestDispatcher.DispatchRequest(OwaContext owaContext)
Microsoft.Exchange.Clients.Owa.Core.OwaRequestEventInspector.OnPostAuthorizeRequest(Object sender, EventArgs e)
System.Web.HttpApplication.SyncEventExecutionStep.System.Web.HttpApplication.IExecutionStep.Execute()
System.Web.HttpApplication.ExecuteStep(IExecutionStep step, Boolean& completedSynchronously)

Solution: The problem was caused with one of the accepted domains, probably a space or other illegal character at the end of the domain name. After reading this article and set the domain name again with the following command in the exchange management shell:

Set-AcceptedDomain -Identity “accepted domain name” -Name “domain.com”

Did this for the last added domain name, because that was when the problem started. After completing this and restarted the server, the problem was solved.

Posted in Blog, Exchange 2010, SBS 2011 by ronnypot at March 13th, 2011.
Tags: , ,

14 Responses to “Reply or forward via OWA gives “An unexpected error occurred and your request couldn’t be handled.””

  1. Dan says:

    Thank you

  2. David B says:

    I’m having this problem and I don’t have any wildcards in my accepted domains. Is there any other issue that could cause this?

    • ronnypot says:

      It doesn’t have to be a wildcard, it can also be a space character so you don’t see it. Have you tried the set-accepteddomain option to reset the domain name?

      • David B says:

        I feel like an idiot and that I’ve been fooled. I finally got it working by changing the NAME of the domain instead of the actual domain. All this time I thought it was the domain that couldn’t have the illegal characters, and it was the name of the domain, which Windows put in as “Windows SBS Accepted Domain”. All the examples I’d read would say “Put ‘ABC Company’ in as your name” when ‘ABC Company’ contains a space and is therefore illegal. I finally figured it out when someone said they fixed it by editing it in EMS, but you can’t edit the domain from there, just the name. Anyway, I surely appreciate your fast reply, and having this info up so people will know what to look for!

        • ronnypot says:

          Thanks for your update maybe this will help other with the same problem

        • tom says:

          I have the same Problem ?
          Where can i fix it ? I have SBS 2011 running,
          owa has the same problem

          my domain name has no “spaces”
          only the Company name … ??

          • ronnypot says:

            Hi,

            Have you tried to solve it with set-accepteddomain command it could be there was a space at the end you don’t see. Otherwise there are more people who had also to remove the spaces from the name, so try that too.

  3. Mike J says:

    Thanks David B, removing the space from the “Windows SBS Accepted Domain” worked…

  4. Netphemera says:

    FYI:

    I had the same problem:Exception message: imceaDomain must be a valid domain name.

    Changing the Accepted Domain(s) Names (i.e., removing the spaces from the name) fixed the problem.

    However, I wanted to get the system up and running ASAP without any downtime due to rebooting the server. In addition to restarting all the Exchange servers, you also need to reboot IIS. That will get you back up and running without performing a full server reboot.

  5. sajith says:

    Hi,
    I removed the space from accepted domain (removing the space from the “Windows SBS Accepted Domain” ). and restart the exchange information services and iis admin services. But i did not reboot the server.
    still it is not working?
    Do i need to restart the server or all exchnage services under services.msc?
    sajith

    • ronnypot says:

      did you used the powershell command to change the setting, I have seen it wasn’t working using the wizards and it worked by just using the powershell command.

  6. sajith says:

    Hi,

    I restarted the server after remove the space. it is working now.
    ((Changing the Accepted Domain(s) Names (i.e., removing the spaces from the name) fixed the problem.))

    cheers

    sajith

Leave a Reply to Dan

Sharing Buttons by Linksku