>

Windows 2008 R2 Hyper-V windows update error 80072EE2 and losing network connection

On a Windows 2008 R2 Hyper-V configuration with 2 network adapters I experienced the following problem: I installed a Windows 2008 R2 guest this was no problem, but when I try to do windows updates I got an “Windows could not search for new updates, An error occurred while checking for new updates for your computer. Error(s) found: Code 80072EE2” error message.

Everthing else looks fine, dns resolving works fine, network browsing looks good, I could access internet pages even the windows update page, but trying to update gives this particulary error.
Tried the same on a windows 2003 guest and everything looks fine. Installed another Windows 2008 R2 server same problem occurres.

Solution: After some more trouble shooting I found that when I start the windows update I lost network connection on that particulary network adapter, even on all other VM’s using that adapter and on the Host. Now I was connected with the other adapter so I didn’t see this behaviour in first place. So I bound the other network adapter to one of the Windows 2008 R2 guests and I could windows update with no error.

Because I would like to know what was causing this problem I found after some more troubleshooting and testing that the problem was caused by the Large send Offload setting enabled on the network adapter. After disabling this setting everything works fine.

The network adapter was causing the trouble was a D-Link DGE-528T Gigabit Ethernet Adapter.

Posted in Blog, Hyper-V, Windows 2008R2 by ronnypot at November 18th, 2010.
Tags: , ,

37 Responses to “Windows 2008 R2 Hyper-V windows update error 80072EE2 and losing network connection”

  1. GFX says:

    Thanks for this solution, I have been looking for a couple of day trying to solve this issue on my test Hyper-V server.

    GFX

  2. V says:

    THX! Really useful!

  3. Tobo says:

    Thank you. That was very useful. I had the same problem.
    Tobo

  4. silentoption says:

    After a week of looking for a solution, this worked for me!

  5. Zorzo says:

    Many thanks, it helped me, works fine 🙂

  6. Lauri says:

    Thanks, faced the same problem with my 2008R2 Hyper-V host.
    Windows Update stopped working after installing Hyper-V role.

  7. Mathias says:

    Damn! it works, thanks!!

  8. Lasse says:

    Thank you for you post. I had the same problem but was unable to find the solution. That is before I found your post.
    You saved me a lot of time! Thanks!

  9. Thanks, you do a great job! very helpful keep doing the good work

  10. bib says:

    Thank you!!

  11. xedgyn says:

    Thanks! Good Job!

  12. Ashton says:

    Thanks so much , I have trying fix this issue for days.
    This was very helpful

  13. Herbert says:

    Many thanks!
    I spent a few days with this problem. Same network card here.

  14. Gunter says:

    Thank You very much!
    I had exact the same issue with Citrix Xenserver V 6.0.2.
    Your solution helped me out!

  15. dlh says:

    You da Man! Thanks a million, we’re on the road to updates now…

  16. marc says:

    This solved as well my problem with a 80072EFE problem on Windows 7 while doing Windows Updates. Thanks a million!

  17. andriy says:

    Thank You!!!
    This article helped me a lot!

  18. me says:

    I had this issue as well but the fix didn’t solve it for me. Clicking the “Install updates” button actually had the server looking at an old WSUS server it was still pointed to instead of the internet (though there was no indication of this in the error). Clicking on “Check online for updates from Microsoft Updates” instead of the “Install Updates” button pointed it towards the website which worked.

  19. MOHIT says:

    THANKSSSSSSSSSSSSSSSSSSSSSSS ALOT SIR………………..

  20. […] respectively. Not too helpful. After searching around for some time I finally found an article that pointed me in the right […]

  21. Martin says:

    Thanks, same issue in ESXi 5.1 with e1000 and vmxnet3 adapters. After disabling offload, everything OK.

  22. Mal says:

    Excellent thanks! Same problem with the same NIC!!

  23. Kiran Kodali says:

    Awesome! That was a hard catch!
    Worked like a charm.
    How did you figure this out?

  24. Karl Abel says:

    You are a Prince among men! Good fix.

  25. Alex P says:

    This is just great, I spent so much time figuring it out … and this solved it!!! Thank you Sir!

  26. This valid for all 80* errors with windows update. Thanks a lot..

  27. Adrian says:

    Thank you so much!

    I had Windows Update error 8024401C on a Windows Server 2012 R2 client running on a 2008 R2 host. All other web traffic worked fine which made it very confusing. Altered this setting on the client and problem solved.

    The host NIC in this case was a Realtek PCI GBE Family Controller (RTL8167).

  28. […] Windows 2008 R2 Hyper-V windows … – Hello, excellent work! I have the same problem with the network card settings but this problem is in hyper-v server core and I don´t know like to change …… […]

  29. baranca says:

    thank you sir, you are wonderful

  30. Mike H says:

    Thanks worked for me!

  31. Dr Den says:

    Superb!! wroking…..any perticulat reason for this settings?

  32. Dave B. says:

    Yipeee!

    Let me note that it may be obvious but this change must be made on the HOST adapter.

Leave a Reply

Sharing Buttons by Linksku